每天拿出一分钟来学习,你的生命会更加精彩。

易语言简单小免杀思路—更名

发布:洪雨2020-3-15 18:42分类: 编程相关 标签: 易语言

运行时不停修改文件名,达到杀毒软件无法定位文件的目的
效果待考证

001mc6OXzy6QqHatAvQ1e&690.jpg


代码:
.版本 2
.支持库 spec 
.子程序 本地代码
.参数 其他代码, 文本型
.局部变量 全部代码, 文本型 
全部代码 = 本地其他 ()
文件更名 (其他代码, 全部代码)
延迟 (100)
处理事件 () 
本地代码 (全部代码) 
.子程序 本地其他, 文本型
.局部变量 key, 文本型 
置随机数种子 ()
.计次循环首 (3, )
    key= key + 字符 (取随机数 (65, 90))
.计次循环尾 ()
返回 (取运行目录 () + “\删除不了” + key) 
.子程序 _按钮1_被单击 
本地代码 (取运行目录 () + “\” + 取执行文件名 ())

温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!

已有 0/2384 人参与

欢迎使用手机扫描访问本站,还可以关注微信哦~