每天拿出一分钟来学习,你的生命会更加精彩。

易语言取多个不重复随机数

发布:洪雨2020-3-18 11:04分类: 编程相关 标签: 易语言

.版本 2
.支持库 spec

.子程序 取不重复的随机数, , 公开, 可以取出多个不同的随机数
.参数 欲取随机数的最小值, 整数型, 可空, 可以被省略。参数必须大于或等于零。本参数如果被省略,默认为 0
.参数 欲取随机数的最大值, 整数型, , 参数必须大于或等于零。
.参数 取的个数, 整数型, , 欲取出随机数的个数,参数必须大于0
.参数 存数值的数组, 整数型, 数组, 取出是随机数都存到这个数组里面
.局部变量 取不重复的随机数aa, 整数型
.局部变量 取不重复的随机数bb, 整数型
.局部变量 取不重复的随机数i, 整数型

删除成员 (存数值的数组, 1, 取数组成员数 (存数值的数组))
置随机数种子 ()
取不重复的随机数aa = 取随机数 (欲取随机数的最小值, 欲取随机数的最大值)
加入成员 (存数值的数组, 取不重复的随机数aa)
.判断循环首 (取数组成员数 (存数值的数组) < 取的个数)
    置随机数种子 ()
    取不重复的随机数aa = 取随机数 (欲取随机数的最小值, 欲取随机数的最大值)
    .计次循环首 (取数组成员数 (存数值的数组), 取不重复的随机数i)
        .判断开始 (取不重复的随机数aa = 存数值的数组 [取不重复的随机数i])
            取不重复的随机数bb = 1
        .默认

        .判断结束

    .计次循环尾 ()
    .判断开始 (取不重复的随机数bb = 0)
        加入成员 (存数值的数组, 取不重复的随机数aa)
        调试输出 (取不重复的随机数aa)
    .默认

    .判断结束
    取不重复的随机数bb = 0
.判断循环尾 ()

温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!

已有 0/2955 人参与

发表评论:

欢迎使用手机扫描访问本站,还可以关注微信哦~