每天拿出一分钟来学习,你的生命会更加精彩。

易语言图片框模仿超级按钮

发布:洪雨2021-11-13 16:41分类: 编程相关 标签: 易语言 编程

QQ截图20211113164242.jpg

.版本 2

.支持库 eAPI

.程序集 窗口程序集1
.程序集变量 移入, 逻辑型

.子程序 _图片框1_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

.如果 (移入 = 假)
    捕获鼠标 (图片框1.取窗口句柄 ())
    移入 = 真
    图片框1.边框 = 3
    图片框1.背景颜色 = #嫩黄
.否则
    .如果真 (横向位置 > 0 且 横向位置 > 图片框1.宽度 或 纵向位置 > 0 且 纵向位置 > 图片框1.高度)
        图片框1.边框 = 0
        图片框1.背景颜色 = #默认色
        移入 = 假
        释放鼠标 ()
    .如果真结束


.如果结束


.子程序 _图片框1_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

信息框 (“按下了信息框”, 0, )
图片框1.边框 = 0
图片框1.背景颜色 = #默认色
移入 = 假
释放鼠标 ()

温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!

已有 0/318 人参与

欢迎使用手机扫描访问本站,还可以关注微信哦~