每天拿出一分钟来学习,你的生命会更加精彩。

易语言图片框复制组件鼠标进入移出事件写法

发布:洪雨2021-11-17 12:10分类: 编程相关 标签: 易语言 编程

这种方法,不仅仅是图片框,可以是任何有鼠标位置移动事件的组件,这样任何组件都可以模仿图形按钮的鼠标滑动效果。

QQ截图20211117121156.png

.版本 2

.支持库 spec

.子程序 _图片框_主载体_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型
.局部变量 tpk, 图片框

tpk = 取事件组件 ()
.如果真 (集_id ≠ 到整数 (tpk.标记))
    集_id = 到整数 (tpk.标记)
    调试输出 (“图片框标记为” + 到文本 (集_id) + “鼠标被称入”)

.如果真结束


.子程序 __启动窗口_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

.如果真 (集_id ≠ 0)
    调试输出 (“图片框标记为” + 到文本 (集_id) + “鼠标被移出”)
    集_id = 0

温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!

已有 0/457 人参与

发表评论:

欢迎使用手机扫描访问本站,还可以关注微信哦~