每天拿出一分钟来学习,你的生命会更加精彩。

易语言移入移除事件(最终解)

发布:洪雨2021-11-19 13:41分类: 编程相关 标签: 易语言 编程

精易模块命令  鼠标移入移出事件()


.版本 2


.子程序 鼠标移入移出事件, 整数型, , 移入返回1,移出返回2,移动中返回3
.参数 控件句柄, 整数型
.参数 移入事件, 子程序指针
.参数 移出事件, 子程序指针

处理事件 ()
.如果 (窗口_取鼠标处窗口句柄 () = 控件句柄)
    .如果真 (是否移入 = 假)
        SetCapture (控件句柄)
        执行子程序_ (移入事件)
        是否移入 = 真
        返回 (1)
    .如果真结束

.否则
    执行子程序_ (移出事件)
    ReleaseCapture ()
    是否移入 = 假
    返回 (2)

.如果结束
SetCapture (控件句柄)
返回 (3)

温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!

已有 0/171 人参与

欢迎使用手机扫描访问本站,还可以关注微信哦~