每天拿出一分钟来学习,你的生命会更加精彩。

易语言取文本中随机一段文本不乱码

发布:洪雨2022-9-1 19:46分类: 编程相关 标签: 易语言

.版本 2
.支持库 spec

.子程序 取随机内容, 文本型
.参数 文件名, 文本型
.参数 次数, 整数型
.局部变量 个数, 整数型
.局部变量 文本, 文本型
.局部变量 x, 整数型
.局部变量 随机文本, 文本型, 静态
.局部变量 最后文本, 文本型
.局部变量 随机数, 整数型

文本 = 到全角 (到文本 (读入文件 (取运行目录 () + “\” + 文件名)))
调试输出 (取文本长度 (文本))
置随机数种子 ()
.计次循环首 (次数, x)
    随机数 = 取随机数 (1, 取文本长度 (文本))
    .判断开始 (随机数 % 2 = 0)
        随机文本 = 取文本中间 (文本, 随机数 - 1, 40)
        调试输出 (随机数)
        .判断开始 (取代码 (到半角 (随机文本), ) > 0)
            最后文本 = 最后文本 + 到半角 (随机文本)
        .默认
            最后文本 = 最后文本 + 随机文本
        .判断结束

    .默认
        随机文本 = 取文本中间 (文本, 随机数, 40)
        调试输出 (随机数)
        .判断开始 (取代码 (到半角 (随机文本), ) > 0)
            最后文本 = 最后文本 + 到半角 (随机文本)
        .默认
            最后文本 = 最后文本 + 随机文本
        .判断结束

    .判断结束

.计次循环尾 ()
调试输出 (最后文本)
返回 (最后文本)

QQ截图20220901194707.jpg

这段代码有一个重点需要注意,就是半角与全角的转换。

洪雨也不是很理解,我感觉应该是转成全角,所有都会变成两个字符。反正半角全角这里是重点,先要深入了解的,可以从这里入手。

温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!

已有 0/197 人参与

发表评论:

欢迎使用手机扫描访问本站,还可以关注微信哦~